Minecraft Server Crashes
Incident Report for PloxHost
Resolved
This incident has been resolved.
Posted May 17, 2022 - 22:15 UTC
Investigating
We are aware of the issue and the team is investigating.
Posted May 17, 2022 - 22:05 UTC
This incident affected: Datacenter Operations: Dallas, Texas (Minecraft Hosting: Dallas, Texas), Datacenter Operations: Frankfurt, Germany (Minecraft Hosting: Frankfurt, Germany), and Datacenter Operations: New York City, New York (Minecraft Hosting: New York City, New York).