Support Email Migrations

Incident Report for PloxHost

Resolved

All emails should be working now. apologies if you have encountered issues submitting tickets.
Posted Mar 24, 2025 - 01:49 UTC

Update

Most of our important support emails are now working as intended. We will post another update once all of our emails are back to normal
Posted Mar 24, 2025 - 00:23 UTC

Identified

We are working on migrating our emails to another provider. Once we get this fixed things should be back to normal.
Posted Mar 23, 2025 - 21:19 UTC
This incident affected: Core Services (Support Center).