Support Site Issues

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Feb 16, 2025 - 05:19 UTC

Investigating

We are currently investigating this issue.
Posted Feb 16, 2025 - 04:25 UTC
This incident affected: Core Services (Support Center).