Billing Panel Accessibly Issues

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 12:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2025 - 09:49 UTC

Update

We are still waiting to hear back from our vendor. if you have any billing issues please submit a ticket: https://support.plox.host/en/tickets/create/step1

and we will assist as best we can. If you can't submit a ticket from the link above send an email to billing@plox.host and a ticket will be created that way.
Posted Feb 18, 2025 - 05:19 UTC

Update

We are still looking into this. We have reached out to our vendor.
Posted Feb 17, 2025 - 20:52 UTC

Update

We are continuing to investigate this issue.
Posted Feb 17, 2025 - 17:11 UTC

Investigating

We are currently investigating this issue.
Posted Feb 17, 2025 - 13:40 UTC
This incident affected: Core Services (billing.plox.host).