eu-finland-mc-bu78.ploxhost.com - Offline

Incident Report for PloxHost

Resolved

SSL has been renewed and node is back online!
Posted Mar 08, 2025 - 21:40 UTC

Identified

SSL has expired on the node, currently in the process of renewing it.
Posted Mar 08, 2025 - 21:40 UTC

Investigating

We are currently investigating the cause of the server being offline.
Posted Mar 08, 2025 - 21:15 UTC
This incident affected: Datacenter Operations: Frankfurt, Germany (Minecraft Hosting: Frankfurt, Germany).