Minecraft Server Startup Service Disruption

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 19:30 UTC

Update

We are continuing to investigate this issue.
Posted Aug 12, 2025 - 02:57 UTC

Investigating

We are currently investigating this incident and will bring a resolution as soon as possible.
Posted Aug 12, 2025 - 02:02 UTC
This incident affected: Datacenter Operations: Dallas, Texas (Minecraft Hosting: Dallas, Texas), Datacenter Operations: Frankfurt, Germany (Minecraft Hosting: Frankfurt, Germany), and Datacenter Operations: New York City, New York (Minecraft Hosting: New York City, New York).