Game Panel Unavailable

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 18:21 UTC

Monitoring

Our game panel and Support site are working again. We will closely monitor the stability of the services.
Posted Sep 01, 2026 - 18:02 UTC

Identified

We have identified the root cause for this issue, we are pushing a fix, and we expect for the services to be back soon.
Posted Sep 01, 2026 - 17:52 UTC

Update

This issue is affecting our support center, game panel, and dedicated control panel. No servers appear to be affected.

Our team is still investigating the root cause for this issue.
Posted Sep 01, 2026 - 17:21 UTC

Investigating

We are currently investigating an issue causing the game panel to be unavailable.

Game servers and Discord bots are not affected and remain operational.

We will provide an update as soon as more information becomes available.
Posted Sep 01, 2026 - 16:49 UTC
This incident affected: Panels (Game Panel, Dedicp Panel) and Core Services (Support Center).