Dallas Network Latency
Incident Report for PloxHost
Resolved
This incident has been resolved.
Posted Apr 29, 2023 - 22:05 UTC
Investigating
We are currently investigating this issue.
Posted Apr 29, 2023 - 21:42 UTC
This incident affected: Datacenter Operations: Dallas, Texas (Minecraft Hosting: Dallas, Texas, VPS Hosting: Dallas, Texas, KVM Hosting: Dallas, Texas, Discord Bot Hosting: Dallas, Texas, Website Hosting: Dallas, Texas, Backup Servers: Dallas, Texas, Dedicated Server Hosting & Colocation: Dallas, Texas).