Billing Panel Captcha Issues

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Dec 27, 2024 - 00:44 UTC

Investigating

We are currently investigating this issue.
Posted Dec 26, 2024 - 23:43 UTC
This incident affected: Core Services (billing.plox.host).