Registry Issues

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Sep 27, 2025 - 16:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2025 - 16:11 UTC

Investigating

We're aware of some interruptions with our Registry service.
We're investigating further and will provide more details soon.
Posted Sep 27, 2025 - 13:45 UTC
This incident affected: Datacenter Operations: Dallas, Texas (Minecraft Hosting: Dallas, Texas), Datacenter Operations: Helsinki, Finland (Minecraft Hosting: Helsinki, Finland), and Datacenter Operations: New York City, New York (Minecraft Hosting: New York City, New York).