Minecraft Node BU 36 Dallas currently down
Incident Report for PloxHost
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 04:27 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2023 - 04:14 UTC
Identified
We have identified a failed drive on the node and are working on restoring data on a new drive.
Posted Feb 13, 2023 - 04:11 UTC