Panel Unreachable

Incident Report for PloxHost

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 04:38 UTC

Investigating

We are aware that our game panel is returning a 502 error message when trying to access it. Our team is investigating the cause of this issue, and we will update you once we have more information.

We apologize for the inconvenience.
Posted Jul 02, 2025 - 06:16 UTC
This incident affects: Panels (Game Panel).