Panel Unreachable

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 21:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2025 - 18:30 UTC

Investigating

We are aware that our game panel is returning a 502 error message when trying to access it. Our team is investigating the cause of this issue, and we will update you once we have more information.

We apologize for the inconvenience.
Posted Jun 10, 2025 - 10:47 UTC
This incident affected: Panels (Game Panel).