Infrastructure-wide DDoS Attacks
Incident Report for PloxHost
Resolved
This incident has been resolved.
Posted Mar 25, 2023 - 02:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2023 - 23:35 UTC
Identified
Our team is working to resolve targeted denial-of-service attacks towards our critical infrastructure. You may notice delays on our websites as our team works to resolve. Thank you for your patience.
Posted Mar 24, 2023 - 20:23 UTC
This incident affected: plox.host (Main Website, billing.plox.host, Control Panel).