Servers are not being automatically created

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 17:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 04:39 UTC

Investigating

We’re currently experiencing an issue where servers are not being created automatically after purchase. Our team is actively investigating and working on a fix.

If you’ve recently made a purchase and haven’t received your server, please reach out to us, and we’ll assist you promptly. Thank you for your patience.
Posted Jul 01, 2025 - 23:01 UTC
This incident affected: Core Services (billing.plox.host).