Billing Portal Outage
Incident Report for PloxHost
Resolved
Appears to have been solved by our upstream. We apologize for any inconvenience- we will continue to monitor.
Posted Jun 01, 2023 - 23:31 UTC
Investigating
Our hosting provider OVH is having an outage which is effecting our billing panel operations. We will update soon.
Posted Jun 01, 2023 - 23:22 UTC
This incident affected: plox.host (billing.plox.host).