Dedicated Control Panel (dedicp.plox.host) Outage
Incident Report for PloxHost
Resolved
This incident has been resolved.
Posted Nov 20, 2022 - 16:35 UTC
Investigating
We are currently investigating this issue.
Posted Nov 19, 2022 - 17:56 UTC
This incident affected: plox.host (Control Panel).