Minecraft Server Startup Service Disruption

Incident Report for PloxHost

Resolved

Our registry system, which manages all Minecraft servers, is now fully operational.

The downtime was caused by an issue with a third-party provider that resulted in the registry going offline, affecting multiple servers. We have since rebuilt the registry on new infrastructure to prevent similar disruptions in the future and have implemented redundancy to ensure this does not happen again.

We sincerely apologize for the inconvenience caused and appreciate your patience while we worked to restore services.
Posted Aug 15, 2025 - 19:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2025 - 19:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 12, 2025 - 19:54 UTC
This incident affected: Datacenter Operations: Dallas, Texas (Minecraft Hosting: Dallas, Texas), Datacenter Operations: Frankfurt, Germany (Minecraft Hosting: Frankfurt, Germany), and Datacenter Operations: New York City, New York (Minecraft Hosting: New York City, New York).