us-dal-mc-bu22 - Offline

Incident Report for PloxHost

Resolved

This incident has been resolved.
Posted May 10, 2025 - 23:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 10, 2025 - 16:02 UTC

Identified

Our team is aware of the recent downtime on our budget Minecraft node 22 and is currently working to bring the node back up.
Posted May 07, 2025 - 23:29 UTC
This incident affected: Datacenter Operations: Dallas, Texas (Minecraft Hosting: Dallas, Texas).