Control Panel Outage
Incident Report for PloxHost
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 14:25 UTC
Monitoring
We are currently monitoring an outage which has been reported.
Posted Jul 31, 2020 - 14:05 UTC
This incident affected: plox.host (Control Panel).